summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorkali <kali@leap.se>2013-02-07 00:32:07 +0900
committerkali <kali@leap.se>2013-02-07 00:32:07 +0900
commitdc4f51f5f71904a6f1d1bc1d062fb82d9211112c (patch)
tree3f12f13735030e2b7e3e92b750810ef6920a4482 /debian/rules
parent97566c6cdadb06889c8f598ba81650e20db76d32 (diff)
generate manpage from docs/man/leap-client.1.rst
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 4 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 9733f76d..2e4af44b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,6 +14,10 @@ PYTHON2=$(shell pyversions -vr)
%:
dh $@ --with python2,sphinxdoc --buildsystem=python_distutils
+override_dh_prep:
+ rst2man docs/man/leap-client.1.rst docs/man/leap-client.1
+ dh_prep
+
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
# run tests!
@@ -25,12 +29,6 @@ test-python%:
override_dh_auto_test: $(PYTHON2:%=test-python%) $(PYTHON3:%=test-python%)
endif
-override_dh_preps:
- # XXX trying to generate the manpage from rst,
- # but not the right override... :(
- rst2html docs/man/leap-client.1.rst docs/man/leap-client.1
- dh_preps
-
#dh_auto_build should be enough to build the python2 version
build-python%: