summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorkali <kali@leap.se>2012-08-10 01:42:55 +0900
committerkali <kali@leap.se>2012-08-10 01:42:55 +0900
commite971fab3f58bbc5b6b8bd387715720dd8c5b2ec1 (patch)
treef885c35a97ea5c845044ae8a76c38cebd12cd6e0 /Makefile
parent24e955629703a4798acc4c26a50e08b2acec8a51 (diff)
working "make deb" using git-buildpackage! :)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 59343dfc..39157a5a 100644
--- a/Makefile
+++ b/Makefile
@@ -45,8 +45,10 @@ $(COMPILED_DIR)/%_rc.py : $(RESOURCE_DIR)/%.qrc
$(PYRCC) $< -o $@
deb:
- @git tag -a debian/$(DEBVER) -m "..."
- @debuild -us -uc -i.git
+ #XXX finish this!
+ #should tag upstream/VERSION in upstream branch...
+ #@git tag -a upstream/$(DEBVER) -m "..."
+ @git-buildpackage --git-ignore-new --git-builder="debuild -us -uc -i'.*|bin|share|lib|local|include|\.git'" --git-upstream-branch=upstream --git-upstream-tree=branch --git-debian-branch=debian
clean :
$(RM) $(COMPILED_UI) $(COMPILED_RESOURCES) $(COMPILED_UI:.py=.pyc) $(COMPILED_RESOURCES:.py=.pyc)