summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMicah Anderson <micah@riseup.net>2013-08-22 14:10:50 -0400
committerMicah Anderson <micah@riseup.net>2013-08-22 14:10:50 -0400
commit6bae67c3e7c66af9e8ce1605070f7e92f247f0cb (patch)
tree64dc7e2588cc5c17fdb6c801877792f83cfcecf3 /Makefile
parent00efccabb1eb6c3597282bc0e095cf2026f75a3b (diff)
parent00d98a47c60764475d97df1c2eb847e20a77cae5 (diff)
Merge tag '0.3.0' into debian
Tag bitmask version 0.3.0 Conflicts: .coveragerc .tx/config NEWS.rst setup.cfg src/leap/base/checks.py src/leap/base/exceptions.py src/leap/base/tests/test_checks.py src/leap/eip/checks.py src/leap/gui/firstrun/login.py src/leap/gui/locale_rc.py src/leap/util/polkit.py tests/test_qt_environment.py tox.ini
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile66
1 files changed, 34 insertions, 32 deletions
diff --git a/Makefile b/Makefile
index fc4a172a..8a6e87e1 100644
--- a/Makefile
+++ b/Makefile
@@ -7,40 +7,52 @@
###### EDIT ######################
#Directory with ui and resource files
RESOURCE_DIR = data/resources
-
+UI_DIR = src/leap/gui/ui
+
#Directory for compiled resources
COMPILED_DIR = src/leap/gui
-
+
+#Directory for (finished) translations
+TRANSLAT_DIR = data/translations
+
+#Project file, used for translations
+PROJFILE = data/bitmask.pro
+
#UI files to compile
-# UI_FILES = foo.ui
-UI_FILES =
+UI_FILES = loggerwindow.ui mainwindow.ui wizard.ui login.ui statuspanel.ui
#Qt resource files to compile
-#images.qrc
-RESOURCES = mainwindow.qrc
-
+RESOURCES = locale.qrc loggerwindow.qrc mainwindow.qrc icons.qrc
+
#pyuic4 and pyrcc4 binaries
-PYUIC = pyuic4
-PYRCC = pyrcc4
-
+PYUIC = pyside-uic
+PYRCC = pyside-rcc
+PYLUP = pyside-lupdate
+LRELE = lrelease
+
+
#################################
# DO NOT EDIT FOLLOWING
-
+
COMPILED_UI = $(UI_FILES:%.ui=$(COMPILED_DIR)/ui_%.py)
COMPILED_RESOURCES = $(RESOURCES:%.qrc=$(COMPILED_DIR)/%_rc.py)
DEBVER = $(shell dpkg-parsechangelog | sed -ne 's,Version: ,,p')
#
-
-all : resources ui
-
-resources : $(COMPILED_RESOURCES)
-
+
+all : resources ui
+
+resources : $(COMPILED_RESOURCES)
+
ui : $(COMPILED_UI)
-
-$(COMPILED_DIR)/ui_%.py : $(RESOURCE_DIR)/%.ui
+
+translations:
+ $(PYLUP) $(PROJFILE)
+ $(LRELE) $(TRANSLAT_DIR)/*.ts
+
+$(COMPILED_DIR)/ui_%.py : $(UI_DIR)/%.ui
$(PYUIC) $< -o $@
-
+
$(COMPILED_DIR)/%_rc.py : $(RESOURCE_DIR)/%.qrc
$(PYRCC) $< -o $@
@@ -51,20 +63,10 @@ deb:
@git-buildpackage --git-ignore-new --git-builder="debuild -us -uc -i'.*|bin|share|lib|local|include|\.git'" --git-upstream-branch=upstream --git-upstream-tree=branch --git-debian-branch=debian
manpages:
- rst2man docs/man/leap-client.1.rst docs/man/leap-client.1
+ rst2man docs/man/bitmask.1.rst docs/man/bitmask.1
apidocs:
@sphinx-apidoc -o docs/api src/leap
-cleandebinstall:
- rm debian/files
- rm debian/leap-client.debhelper.log
- rm debian/leap-client.postinst.debhelper
- rm debian/leap-client.postrm.debhelper
- rm debian/leap-client.prerm.debhelper
- rm debian/leap-client.substvars
- rm -rf debian/leap-client/
-
-
-clean :
- $(RM) $(COMPILED_UI) $(COMPILED_RESOURCES) $(COMPILED_UI:.py=.pyc) $(COMPILED_RESOURCES:.py=.pyc)
+clean :
+ $(RM) $(COMPILED_UI) $(COMPILED_RESOURCES) $(COMPILED_UI:.py=.pyc) $(COMPILED_RESOURCES:.py=.pyc)