summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorkali <kali@leap.se>2013-01-30 14:46:56 +0900
committerkali <kali@leap.se>2013-01-30 14:51:24 +0900
commit263b502ad844b1c96f71364b82bd46bbfe2f8142 (patch)
tree586f20de1a4a56789142c7dcb43bdecaa425b24f /Makefile
parent4c406dcc3ff886713e63b11750fe9b1cbea24441 (diff)
rename manpage
I am also commiting the manpage itself temporarily, we should leave only the .rst in the repo!
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 39157a5a..451ca201 100644
--- a/Makefile
+++ b/Makefile
@@ -50,5 +50,11 @@ deb:
#@git tag -a upstream/$(DEBVER) -m "..."
@git-buildpackage --git-ignore-new --git-builder="debuild -us -uc -i'.*|bin|share|lib|local|include|\.git'" --git-upstream-branch=upstream --git-upstream-tree=branch --git-debian-branch=debian
+manpages:
+ rst2man docs/man/leap-client.1.rst docs/man/leap-client.1
+
+apidocs:
+ @sphinx-apidoc -o docs/api src/leap
+
clean :
$(RM) $(COMPILED_UI) $(COMPILED_RESOURCES) $(COMPILED_UI:.py=.pyc) $(COMPILED_RESOURCES:.py=.pyc)