summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMicah Anderson <micah@riseup.net>2013-08-22 15:41:53 -0400
committerMicah Anderson <micah@riseup.net>2013-08-22 15:55:02 -0400
commit25a07f9077f01c0616c2d06ada5d7a7e230ade0a (patch)
tree1c67e73e3546c40b559558f550e6d32d2fc46b04
parente5049eee8e8df39bd4ba80c19404e0a064f97908 (diff)
Hack to test
-rw-r--r--MANIFEST.in5
-rw-r--r--debian/clean2
-rwxr-xr-xsetup.py4
3 files changed, 7 insertions, 4 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index a4d18e0b..90ba716a 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -4,5 +4,6 @@ recursive-include docs api/* config/* dev/* man/* pkg/* testers/* user/*
prune docs/_build
prune docs/covhtml
include versioneer.py
-include src/leap/util/reqs.txt
-include src/leap/crypto/tests/wrongcert.pem
+include src/leap/bitmask/util/reqs.txt
+include src/leap/bitmask/crypto/tests/wrongcert.pem
+
diff --git a/debian/clean b/debian/clean
index 322f3a67..698f87e3 100644
--- a/debian/clean
+++ b/debian/clean
@@ -1 +1,3 @@
docs/man/leap-client.1
+MANIFEST
+src/leap.bitmask.egg-info/*
diff --git a/setup.py b/setup.py
index 09d0661c..2c80eb5c 100755
--- a/setup.py
+++ b/setup.py
@@ -52,14 +52,14 @@ trove_classifiers = [
parsed_reqs = utils.parse_requirements()
cmdclass = versioneer.get_cmdclass()
-leap_launcher = 'bitmask=leap.app:main'
+leap_launcher = 'bitmask=leap.bitmask.app:main'
from setuptools.command.develop import develop as _develop
def copy_reqs(path, withsrc=False):
# add a copy of the processed requirements to the package
- _reqpath = ('leap', 'util', 'reqs.txt')
+ _reqpath = ('leap', 'bitmask', 'util', 'reqs.txt')
if withsrc:
reqsfile = os.path.join(path, 'src', *_reqpath)
else: