Remove --upgrade for pip since causes problems.