summaryrefslogtreecommitdiff
path: root/ics-openvpn-stripped/main/openvpn/src/plugins/down-root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ics-openvpn-stripped/main/openvpn/src/plugins/down-root/Makefile.am')
-rw-r--r--ics-openvpn-stripped/main/openvpn/src/plugins/down-root/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/ics-openvpn-stripped/main/openvpn/src/plugins/down-root/Makefile.am b/ics-openvpn-stripped/main/openvpn/src/plugins/down-root/Makefile.am
new file mode 100644
index 00000000..7ca5a4e1
--- /dev/null
+++ b/ics-openvpn-stripped/main/openvpn/src/plugins/down-root/Makefile.am
@@ -0,0 +1,24 @@
+#
+# OpenVPN (TM) Down Root Plugin -- OpenVPN Plugin
+#
+# Copyright (C) 2012 Alon Bar-Lev <alon.barlev@gmail.com>
+#
+
+MAINTAINERCLEANFILES = \
+ $(srcdir)/Makefile.in
+
+AM_CFLAGS = \
+ -I$(top_srcdir)/include \
+ $(OPTIONAL_CRYPTO_CFLAGS)
+
+if ENABLE_PLUGIN_DOWN_ROOT
+plugin_LTLIBRARIES = openvpn-plugin-down-root.la
+dist_doc_DATA = README.down-root
+endif
+
+openvpn_plugin_down_root_la_SOURCES = \
+ down-root.c \
+ down-root.exports
+openvpn_plugin_down_root_la_LDFLAGS = $(AM_LDFLAGS) \
+ -export-symbols "$(srcdir)/down-root.exports" \
+ -module -shared -avoid-version -no-undefined