summaryrefslogtreecommitdiff
path: root/ics-openvpn-stripped/main/openvpn/src/plugins/down-root/Makefile.am
diff options
context:
space:
mode:
authorParménides GV <parmegv@sdf.org>2014-07-31 12:09:49 +0200
committerParménides GV <parmegv@sdf.org>2014-07-31 12:09:49 +0200
commit0393ba6656ce6cf679a2c4663275b3ed0f1a34b9 (patch)
treef000311e97598ab3fc42e2bea23e6cb342ad166c /ics-openvpn-stripped/main/openvpn/src/plugins/down-root/Makefile.am
parentb28eeb08e8ec3baafdd9388cc5b70c6c84db9cf1 (diff)
Updated ics-openvpn to rev 859 + no 2nd notification.
Diffstat (limited to 'ics-openvpn-stripped/main/openvpn/src/plugins/down-root/Makefile.am')
-rw-r--r--ics-openvpn-stripped/main/openvpn/src/plugins/down-root/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/ics-openvpn-stripped/main/openvpn/src/plugins/down-root/Makefile.am b/ics-openvpn-stripped/main/openvpn/src/plugins/down-root/Makefile.am
new file mode 100644
index 00000000..7ca5a4e1
--- /dev/null
+++ b/ics-openvpn-stripped/main/openvpn/src/plugins/down-root/Makefile.am
@@ -0,0 +1,24 @@
+#
+# OpenVPN (TM) Down Root Plugin -- OpenVPN Plugin
+#
+# Copyright (C) 2012 Alon Bar-Lev <alon.barlev@gmail.com>
+#
+
+MAINTAINERCLEANFILES = \
+ $(srcdir)/Makefile.in
+
+AM_CFLAGS = \
+ -I$(top_srcdir)/include \
+ $(OPTIONAL_CRYPTO_CFLAGS)
+
+if ENABLE_PLUGIN_DOWN_ROOT
+plugin_LTLIBRARIES = openvpn-plugin-down-root.la
+dist_doc_DATA = README.down-root
+endif
+
+openvpn_plugin_down_root_la_SOURCES = \
+ down-root.c \
+ down-root.exports
+openvpn_plugin_down_root_la_LDFLAGS = $(AM_LDFLAGS) \
+ -export-symbols "$(srcdir)/down-root.exports" \
+ -module -shared -avoid-version -no-undefined