summaryrefslogtreecommitdiff
path: root/app/openvpn/sample/Makefile.am
diff options
context:
space:
mode:
authorParménides GV <parmegv@sdf.org>2015-06-04 19:20:15 +0200
committerParménides GV <parmegv@sdf.org>2015-06-04 19:20:15 +0200
commit27594eeae6f40a402bc3110f06d57975168e74e3 (patch)
treecdabf6571e6f4ff07205fd6921d8095539a1fcdc /app/openvpn/sample/Makefile.am
parent8dc4f58d96892fbfd83094fb85b1d17656035290 (diff)
ics-openvpn as a submodule! beautiful
ics-openvpn is now officially on GitHub, and they track openssl and openvpn as submodules, so it's easier to update everything. Just a git submodule update --recursive. I've also set up soft links to native modules from ics-openvpn in app, so that we don't copy files in Gradle (which was causing problems with the submodules .git* files, not being copied). That makes the repo cleaner.
Diffstat (limited to 'app/openvpn/sample/Makefile.am')
-rw-r--r--app/openvpn/sample/Makefile.am34
1 files changed, 0 insertions, 34 deletions
diff --git a/app/openvpn/sample/Makefile.am b/app/openvpn/sample/Makefile.am
deleted file mode 100644
index be30c88a..00000000
--- a/app/openvpn/sample/Makefile.am
+++ /dev/null
@@ -1,34 +0,0 @@
-#
-# OpenVPN -- An application to securely tunnel IP networks
-# over a single UDP port, with support for SSL/TLS-based
-# session authentication and key exchange,
-# packet encryption, packet authentication, and
-# packet compression.
-#
-# Copyright (C) 2002-2010 OpenVPN Technologies, Inc. <sales@openvpn.net>
-# Copyright (C) 2006-2012 Alon Bar-Lev <alon.barlev@gmail.com>
-#
-
-MAINTAINERCLEANFILES = \
- $(srcdir)/Makefile.in
-
-EXTRA_DIST = \
- sample-plugins \
- sample-config-files \
- sample-windows \
- sample-keys \
- sample-scripts
-
-if WIN32
-sample_DATA = \
- client.ovpn \
- server.ovpn \
- sample-windows/sample.ovpn
-
-client.ovpn: sample-config-files/client.conf
- -rm -f client.ovpn
- cp "$(srcdir)/sample-config-files/client.conf" client.ovpn
-server.ovpn: sample-config-files/server.conf
- -rm -f server.ovpn
- cp "$(srcdir)/sample-config-files/server.conf" server.ovpn
-endif