summaryrefslogtreecommitdiff
path: root/www/setup.py
diff options
context:
space:
mode:
authorelijah <elijah@riseup.net>2016-09-16 13:54:10 -0700
committerKali Kaneko (leap communications) <kali@leap.se>2016-09-22 11:39:47 -0400
commitae5a20d059209f2027c05820dc3b4cfe7346c8a8 (patch)
tree3ddc591e3d8b9fc9721c198bb83976b1d6705490 /www/setup.py
parentbb82515bca6ff6e6b74718bf946faf3747e40002 (diff)
[pkg] fix www (aka bitmask_js) when run in "development mode"
this change allows you to edit the js and have the changes reflected immediately in the app.
Diffstat (limited to 'www/setup.py')
-rw-r--r--www/setup.py54
1 files changed, 0 insertions, 54 deletions
diff --git a/www/setup.py b/www/setup.py
deleted file mode 100644
index d45dbbd8..00000000
--- a/www/setup.py
+++ /dev/null
@@ -1,54 +0,0 @@
-#!/usr/bin/env python
-# -*- coding: utf-8 -*-
-# setup.py
-# Copyright (C) 2016 LEAP Encryption Acess Project
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-"""
-Setup file for leap.bitmask-www
-"""
-
-from setuptools import setup
-
-import datetime
-import time
-
-
-# TODO add all the node steps in this setup too.
-# Right now it's expected that you run the node commands by hand
-# i.e., 'make build'
-
-now = datetime.datetime.now()
-timestamp = time.strftime('%Y%m%d%H%M', now.timetuple())
-
-setup(
- name='leap.bitmask_www',
- version='0.1.%s' % timestamp,
- description='Bitmask html/js UI',
- long_description=open('notes-python.txt').read(),
- author='LEAP Encrypted Access Project',
- author_email='info@leap.se',
- url='http://leap.se',
- namespace_packages=['leap'],
- packages=['leap.bitmask_www'],
- package_data={
- '': ['public/*',
- 'public/css/*',
- 'public/fonts/*',
- 'public/img/*',
- 'publlic/js/*',
- ]
- }
-)