diff options
author | Kali Kaneko <kali@leap.se> | 2015-07-21 00:52:27 -0400 |
---|---|---|
committer | Ivan Alejandro <ivanalejandro0@gmail.com> | 2015-07-22 15:48:09 -0300 |
commit | c3919c78af24e7a29653341fe631781ae47fae3d (patch) | |
tree | a1bfd7273076e1072b046d42b74c2844bf80c8e0 /setup.py | |
parent | 325dded67dd9ca0ad84e323bed7b6b157d2f870b (diff) |
[pkg] add empty __init__ on soledad folder
otherwise the module cannot be imported (in the pseudo-pkg produced by
the sumo tarball)
- Releases: 0.9.0
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 10 |
1 files changed, 8 insertions, 2 deletions
@@ -274,6 +274,14 @@ class cmd_sdist(versioneer_sdist): # We need to copy the requirements to the specified path # so that the client has a copy to do the startup checks. copy_reqs(base_dir, withsrc=True) + with open(os.path.join(base_dir, + 'src', 'leap', '__init__.py'), + 'w') as nuke_top_init: + nuke_top_init.write('') + with open(os.path.join(base_dir, + 'src', 'leap', 'soledad', '__init__.py'), + 'w') as nuke_soledad_ns: + nuke_soledad_ns.write('') def make_distribution(self): # add our extra files to the list just before building the @@ -301,8 +309,6 @@ class cmd_sdist(versioneer_sdist): self.filelist.extend(all_module_files) freeze_pkg_ver( src_path + "/_version.py", vdict[module], "sumo") - with open('src/leap/__init__.py', 'w') as nuke_top_init: - nuke_top_init.write('') # In addition, we want the tarball/zipfile to have -SUMO in the # name, and the unpacked directory to have -SUMO too. The easiest |