diff options
author | Kali Kaneko <kali@leap.se> | 2016-03-04 11:44:41 -0400 |
---|---|---|
committer | Kali Kaneko <kali@leap.se> | 2016-04-19 09:59:18 -0400 |
commit | 6fd1c73db49c5e1e08cf7963017470511fef0059 (patch) | |
tree | 04a73adebb69176653f44880debb65980dae4eaa /setup.py | |
parent | cea88f895f3fe2fadd2a59f9301e84cb13020dd4 (diff) |
[feature] add bitmask_cli entrypoint
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 9 |
1 files changed, 5 insertions, 4 deletions
@@ -170,9 +170,6 @@ else: reqfiles=["pkg/requirements-leap.pip"]) -leap_launcher = 'bitmask=leap.bitmask.app:start_app' - - def copy_reqs(path, withsrc=False): # add a copy of the processed requirements to the package _reqpath = ('leap', 'bitmask', 'util', 'reqs.txt') @@ -480,6 +477,10 @@ if IS_LINUX: extra_options = {} +gui_launcher = 'bitmask=leap.bitmask.app:start_app' +bitmask_cli = 'bitmask_cli=leap.bitmask.cli.bitmask_cli:main' + + setup( name="leap.bitmask", package_dir={"": "src"}, @@ -515,7 +516,7 @@ setup( zip_safe=False, platforms="all", entry_points={ - 'console_scripts': [leap_launcher] + 'console_scripts': [gui_launcher, bitmask_cli] }, **extra_options ) |